Export PDF or CSV from Email Stats page produces error message
Incident Report for Bananatag
Resolved
This incident has been resolved.
Posted Apr 03, 2019 - 12:58 PDT
Identified
This issue has been identified and our team is actively troubleshooting. We expect to have a solution to this issue shortly.
Posted Apr 03, 2019 - 09:09 PDT
This incident affected: app.bananatag.com.