Tracked links are slow to load for some users
Incident Report for Bananatag
Postmortem

The degraded performance was identified to be caused by a third-party who was actively attempting to overload one of our systems by directing a large amount of traffic to it.

Our team was able to identify the incoming traffic and prevent it from further affecting the performance of the system. We can confirm that this did not impact the security, confidentiality or integrity of customer data.

During the period of degraded performance, there may have been intermittent latency on processing open counting and link redirects events, and in some rare cases, some events may not have been processed resulting in links not redirecting.

While not all users would have experienced the issue, it is possible that some users may have intermittently experienced the degradation as early as 12:00 PM PST on December 3rd.

Posted Dec 04, 2019 - 21:31 PST

Resolved
This issue is now resolved.
Posted Dec 04, 2019 - 21:29 PST
Monitoring
After identifying the issue, our engineering team has implemented a fix that has addressed the issue.

We are monitoring the results to ensure that this issue has been resolved.
Posted Dec 04, 2019 - 16:25 PST
Investigating
We have received reports that tracked links are slow to load for some users.

While links do eventually load, and metrics are recorded accurately, our engineering team is currently investigating this issue to identify the root cause.
Posted Dec 04, 2019 - 15:42 PST
This incident affected: Processing tracked events.