Issues loading drafts in Email Designer 3.0
Incident Report for Bananatag
Resolved
After monitoring the situation, this issue seems to be resolved.

If you are still experiencing this issue access drafts in Email Designer 3, please contact support@bananatag.com
Posted Nov 27, 2019 - 08:36 PST
Monitoring
We have identified the cause of the issue and have implemented a fix. We are monitoring the situation to ensure that the issue has been resolved.
Posted Nov 26, 2019 - 13:44 PST
Investigating
We are receiving reports that some users are unable to access some of their Email Designer 3.0 drafts via app.bananatag.com and our add-ins.

We are investigating the issue to identify the root cause.

If you are currently experiencing this issue, please contact support@bananatag.com
Posted Nov 26, 2019 - 13:30 PST
This incident affected: app.bananatag.com and Outlook for Windows add-in.